Trying to embed Nabble forum on my website

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Trying to embed Nabble forum on my website

jacobanddebbieacro
I am using webflow to make my site.  I can drop an element on my page which contains an html embed.  It's not working though.  There is a link to my forum, which takes me to the forum, but i believe the forum is supposed to show up on my page.  What do I do.  

https://www.jacobanddebbieacro.com/forum

Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

Raven<Nabble>
Administrator
It appears that it's a HTTPS issue, as per the mixed content error in the console.

If you want to embed on a HTTPS site, you will need to set the forum to https.
First you need to set a custom domain for your forum, with the same base domain as the site you're embedding on. For example, forum.jacobanddebbieacro.com. You'll need to set a CNAME record that points to n8.nabble.com.
more information:
http://jacobanddebbieacro.89018.n8.nabble.com/help/DNSConfiguration.jtp

Once you've done that, I'll be able to enable https on our end.
Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

jacobanddebbieacro
I inserted Nabble into the c name record on Name Silo.  I included a screenshot so you can see if that is all right.  

Thank you for your help.  So you can enable https for the forum?
Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

Raven<Nabble>
Administrator
I've enabled https.
I had to wait for the DNS changes to propagate before I could do it.
Try updating your embed code which you can get from Options > Embedding Options.
Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

jacobanddebbieacro
It's still not quite working.  It says it is not secure.  This is the code it gave me.  It looks right

jacobanddebbieacro
<script src="https://forum.jacobanddebbieacro.com/embed/f1"></script>
I set it to use my domain name and I set a cname for my forum.  forum.jacobanddebbieacro.com



Do you know why it isn't working?  Also, is it possible I need to have my webhost allow this forum.  Webflow.

Thanks



Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

jacobanddebbieacro
The above message I meant to include this screenshot
Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

Raven<Nabble>
Administrator
It's working now. Maybe it was a cache issue.
Reply | Threaded
Open this post in threaded view
|

Re: Trying to embed Nabble forum on my website

jacobanddebbieacro
My forum works now.  Thank you very much for the help.  Although on Chrome is still says not secure.  I tried on firefox and safari and there was no problem.  So something is still wrong with chrome.  Also I am trying to get the nabble blog to work too.  It it not working yet.  I have it embedded in the same way as the forum.  It is here

https://blog.jacobanddebbieacro.com/

The blog is a blue link on all three browsers.  I tried removing all the cookies and that didn't do anything

Thanks