Pictures/Links terminating rest of message in a reply submitted by email

classic Classic list List threaded Threaded
20 messages Options
Reply | Threaded
Open this post in threaded view
|

Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
Ok, so I've done more testing on this issue that I originally started here: http://support.nabble.com/Inline-Images-sent-via-email-sometimes-work-and-sometimes-don-t-td7586838.html 

So what I've been able to narrow down is whenever you have an image in a post delivered via email subscription, if you reply to that email - the resulting post made to the forum is truncated where the image would be.  (I also find that this also happens when there is a link to a website as well)

If you go to the forum and click to edit that post, then you can see the entire post and it looks like this:

The truncation occurs as soon as it gets to the left bracket in front of the URL.

Here is a link to the samples I was testing:
http://sudsol.1100894.n5.nabble.com/Testing-of-reply-to-images-embedded-in-email-td532.html 

I have also seen this consistently in my signature line (which has a link to my website).  So I decide to do some testing the same way, but using a URL link instead of a picture and I get the same results (message truncated as soon as it reaches the URL).

Here is a link to that thread of tests: http://sudsol.1100894.n5.nabble.com/Testing-of-reply-to-a-URL-embedded-in-an-email-td534.html 

So then I did one final test - which was to include a URL in a brand new topic email sent via email to the list (to narrow down if the problem was just in replies or whether it was for all posts via email).  What I found was that the initial new topic post handled the URL just fine.  It's the reply (via email) to an existing topic that causes the problem.

Here is the link to the new topic post & reply to that post: http://sudsol.1100894.n5.nabble.com/Test-of-a-brand-new-message-with-a-URL-in-it-td537.html 

In all circumstances, if you go to edit the reply post on the website, you see the entire message is there, it's just not being displayed properly (and it's also not being sent to the subscribers properly) - both truncate at the instance of the picture or URL.

This is definitely a bug.
Coleen
Reply | Threaded
Open this post in threaded view
|

Re: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
So, do you want all images, urls, etc. showed everywhere?  Even if they have already been showed before?
My test forum.
Reply | Threaded
Open this post in threaded view
|

Re: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
Yes

Coleen Astalos
[hidden email]

"Pedro <Nabble> [via Nabble Support]" <[hidden email]> wrote:

So, do you want all images, urls, etc. showed everywhere?  Even if they have already been showed before?
My test forum.



If you reply to this email, your message will be added to the discussion below:
http://support.nabble.com/Pictures-Links-terminating-rest-of-message-in-a-reply-submitted-by-email-tp7587354p7587421.html
To unsubscribe from Pictures/Links terminating rest of message in a reply submitted by email, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
In reply to this post by Pedro <Nabble>
Any progress on this?
Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
In reply to this post by Pedro <Nabble>

This is a bug that needs to be fixed. 

 

I've done testing and can easily reproduce the problem every time.  If a URL or picture is sent in an email reply (that seems to be the key - only happens via email and only happens with a REPLY to an existing topic - not a newly started topic), then the message stops (truncates) as soon as the URL or picture is reached.

 

If you view the post on the website, or receive the post via email subscription, then all you get is the message up to the point of the URL or embedded picture (neither the URL or picture is shown).

 

If you edit that same post on the website, the rest of the post is there - it's just not all displaying for some reason. 

 

As an example, I’m including a link to a website here (and below the link is the rest of my signature as well as the email from you that I am replying to).  You will see that the message terminates with this URL (even though there is more information included below the link).  URL Is here:  http://www.sudsol.org

 

Rest of message following the URL.  I'm CC'ing your email address on this message so you can see that there really was stuff after the URL that didn't get included.

Coleen

 

Coleen Astalos, Stampin' Up! Demonstrator
Alamosa, CO,
[hidden email]
See my website at
http://alamosa.stampinup.net
Are you a demonstrator?
Join me on SUDSOL - Your 24/7 Upline!

 

From: Pedro <Nabble> [via Nabble Support] [[hidden email]]
Sent: Friday, October 18, 2013 3:03 PM
To: Coleen_Astalos
Subject: Re: Pictures/Links terminating rest of message in a reply submitted by email

 

So, do you want all images, urls, etc. showed everywhere?  Even if they have already been showed before?

My test forum.

 


To unsubscribe from Pictures/Links terminating rest of message in a reply submitted by email, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
Pedro, I copied you via email on the post above so you could see what the email I sent to the forum looked like, so you could see where the post is cut off.

What macro processes incoming emails to a forum? And is there a different macro that processes replies to a forum topic?  I think comparing those two would reveal the solution as the problem does not occur on a new post to the category, only on a reply post.

Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
Working on it.
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
In reply to this post by Coleen_Astalos
Coleen_Astalos wrote
I've done testing and can easily reproduce the problem every time.  If a URL
or picture is sent in an email reply (that seems to be the key - only
happens via email and only happens with a REPLY to an existing topic - not a
newly started topic), then the message stops (truncates) as soon as the URL
or picture is reached.
I don't think so, it might have another issue that we are not seeing. Look, I could send links in my reply via email:
http://pedro-3.1104361.n5.nabble.com/Testing-reply-url-td10.html
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos

Humm…  Do you suppose it has to do with what email program is sending the email?  I'm using Outlook 2007 to send my emails and it always happens for me.  But looking at your testing, it didn't happen for you.

 

I'll do some testing sending my emails using Gmail instead and see what happens.  Will let you know.

Coleen

 

Coleen Astalos, Stampin' Up! Demonstrator
Alamosa, CO, [hidden email]
See my website at http://alamosa.stampinup.net
Are you a demonstrator? Join me on SUDSOL - Your 24/7 Upline!

 

From: Pedro <Nabble> [via Nabble Support] [mailto:[hidden email]]
Sent: Tuesday, October 29, 2013 8:28 PM
To: Coleen_Astalos
Subject: RE: Pictures/Links terminating rest of message in a reply submitted by email

 

Coleen_Astalos wrote

I've done testing and can easily reproduce the problem every time.  If a URL
or picture is sent in an email reply (that seems to be the key - only
happens via email and only happens with a REPLY to an existing topic - not a
newly started topic), then the message stops (truncates) as soon as the URL
or picture is reached.

I don't think so, it might have another issue that we are not seeing. Look, I could send links in my reply via email:
http://pedro-3.1104361.n5.nabble.com/Testing-reply-url-td10.html

My test forum.

 


To unsubscribe from Pictures/Links terminating rest of message in a reply submitted by email, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
Great. Let me know.
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
In reply to this post by Coleen_Astalos
Well, it definitely seems to relate to Outlook.  Emails sent thru Gmail with a link or via my other WebMail program don't have this problem.  But emails sent via Outlook 2007 do.

I did 3 tests in Outlook 2007:
1) Sending as I normally do - with the link being made active by Outlook as soon as finish typing the link.  
The results of this is the truncation at the point the link would be.

2) Sending the same as 1, but not letting Outlook automatically make the link active (Outlook uses Microsoft Word for the editor and it turns links to active).  
The reulsts of this is still a truncation, but at the point where the link would be, I see the following:
" target="_top" rel="nofollow" link="external"> and the rest of the message is truncated.

3) If I force Outlook to send the message as plain text it comes through fine.

So it's something with the HTML formatting of the message from Outlook.  Now what?  Outlook is a highly used email program - especially for business users (such as my group).

Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
Is it possible for you to give me the html message outlook create when you send an url? It must has a tag that is breaking our code.
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
Ok, I've loaded two different files.

The first one is a new topic post (not a reply) and the link comes thru fine.  The link is on line 869-870 of the file.
New_Post_to_Business_Section.htm

This second one is a reply to that first email and the message is truncated at the link.  The link is on line 878-880 of the file.
REPLY_to_New_Post_to_Business_Section.htm

Here is the posts on Nabble: http://sudsol.1100894.n5.nabble.com/New-Post-to-Business-Section-td1332.html 

Thanks,
Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
Adding them as files here might not have worked (when I click on them it doesn't show the HTML coding, but tries to display the page).  So I'll email them to you as attachments.
Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
Please, do a test for me:
When you go to reply an topic using outlook, does it append the first post on its reply? If so, delete it and send only the reply it self. See if it truncates.
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
This post was updated on .
Looks like you might be narrowing the problem down.  

Yes, Outlook automatically appends a copy of the original message.  There are two options for removing the original message:
1) Deleting the text that is quoted when typing the reply.  
2) Turning off the option in outlook to not quote the original message.  
I tested both options and both of them work - the message is not truncated.

You can see the tests here: http://sudsol.1100894.n5.nabble.com/New-post-via-Outlook-to-business-topic-td1380.html

Let me know if you want to see the HTML for any of these emails.
Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
When you append the last topic to your reply, your software adds a html div like this "<div = " just before the beginning of the last topic append.
When you reply, try to spot it and replace with "<div ", it might be a configuration on outlook. Or you can tell your users to do not copy the original message.

In the meantime, we will try to set up our side to deal with it.
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
In Outlook you are unable to see or edit the HTML before sending the message.  I can only retrieve it after the fact by looking at the email in my sent folder and saving it as HTML.  So I hope there is something you can do on your end to correct the problem.
Thanks,
Coleen
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Pedro <Nabble>
Please, try to post via outlook again. It has been fixed.
My test forum.
Reply | Threaded
Open this post in threaded view
|

RE: Pictures/Links terminating rest of message in a reply submitted by email

Coleen_Astalos
Yeah!  Tested and fixed.
Coleen