Quantcast

Missing Date in Emails

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Missing Date in Emails

GregChapman
He Pedro,

In the last couple of days I've used the "Send Email" screen twice on my forum at:
http://seahawk-forum.968426.n3.nabble.com/
sending a copy to myself.

Both copy messages have arrived without showing a date in my email program. It seems the "Date:" mail header line is missing from the message.

Registration emails are arriving normally and do show a date.

Can you confirm this is a recently introduced bug?
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

Pedro <Nabble>
In my test forum it worked fine. I'll test in yours.
My test forum.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

Pedro <Nabble>
In reply to this post by GregChapman
I tested, it also seems ok. Have it happened again?
My test forum.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

GregChapman
Still wrong here!

Have sent an email showing a full email including headers and an image showing how it appears in my email client.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

Pedro <Nabble>
I don't understand why and how your from and to headers are different.
My test forum.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

Pedro <Nabble>
In reply to this post by GregChapman
Can you test with another email account? And also test another forum, please.
My test forum.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

GregChapman
Pedro <Nabble> wrote
Can you test with another email account? And also test another forum, please.
The screen dump I sent shows examples of where I send a messages to new users (all those with the Subject "SeaHawk Forum Registration" ). Somewhere between 27 October and 12 November the date stops being sent in the copies I receive. It also shows one (Subject "Date Test") where I used my test user account to send to me as Administrator. So you have tests of two users. Interestingly, other types of message from the forum do show a date, e.g. the most recent message "New user: timperkins".

I have just done a test on the forum:
http://www.rustonreaches.co.uk/forum.html
I sent a message to my test user "GregC" while logged in on my Admin account "RustonHouse". My test user received a message that included a date. My administrator copy shows a blank date.

I'll email those two mails showing all headers immediately after sending this.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

Pedro <Nabble>
Greg, please, try again on http://www.rustonreaches.co.uk/forum.html .
We made a new release on this server tonight, it may work now.
My test forum.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

GregChapman
Hi Pedro,

The position is still the same. There is no "Date:" header in the copy sent to my Admin account. It only has a "Delivery Date:" header line. Whereas the message sent to my test user account does include the proper "Date:" header.

Don't do your tests using GMail! I see the app on my Android phone, in typical Google non-RFC compliant mode, does show a date on both messages. I guess it must be using the "Delivery Date:" header to do this. :-(
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

Pedro <Nabble>
Yes, I was trying to reproduce it with gmail. But even using aol mail I couldn't receive a miss date email.
We are investigating it.
My test forum.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Missing Date in Emails

GregChapman
Hi Pedro,
Pedro <Nabble> wrote
Yes, I was trying to reproduce it with gmail. But even using aol mail I couldn't receive a miss date email.
We are investigating it.
I copied myself a message sent from the "Send Email" screen from my "SeaHawk" forum tonight tonight and it still came through with no date. Here are images from the earlier message I mentioned...

Results do vary according to the device/app used, but it seems pretty conclusive to me that this is a missing Date header line issue.

Here's the message referred to earlier shown on my primary desktop mail client in "View Source" mode. No "Date: header so a blank date field...

nPOPuk Screen Image
Same message on my Tesco Hudl Tablet. (Android 4.2.2 - This runs one of the most plain vanilla versions of Android I have come across) No date so it shows the Unix default!

Android Tablet
OTOH, a heavily customised Android (Galaxy S3 Mini (Android 4.1.2) does show a date (presumably using the Delivery-date: header line as a fall-back)...

Samsung Galaxy S3 Mini
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Loading...