Delete messages email

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Delete messages email

Harvey
We've moved over to Zenforo.

Because there is no migration tool, we've moved some of our most important content manually. Not an easy task.

I'd like to start deleting things in the old forum as they are moved over, but don't want our members getting a bunch of email.

Any way to disable that feature?
HTTPS Please!
Reply | Threaded
Open this post in threaded view
|

Re: Delete messages email

GregChapman
This post was updated on .
Looks like wrapping the following code from the macro "send_deleted_nodes_email" within
<n.comment.> ... </n.comment.>
 tags should do it.

(This is untested by me!)  
         <n.loop.>
            <n.if.current_user.is_registered>
                <then>
                    <n.new_email.>
                        <n.nodes_list.attach_nodes/>
                        <n.send>
                            <to.current_user.user_email/>
                            <to_name.current_user.name/>
                            <subject><t>Deleted posts</t></subject>
                            <text_part.deleted_nodes_text/>
                            <bounce_to.current_user.bounces_address/>
                        </n.send>
                    </n.new_email.>
                </then>
            </n.if.current_user.is_registered>
        </n.loop.>

Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
GregHelp - Building a set of answers to Nabble FAQs.
Reply | Threaded
Open this post in threaded view
|

Re: Delete messages email

Harvey
Thanks Greg.

I am getting this:

 Error: parse exception in custom_tweak:send_deleted_nodes_email - unclosed tag: n.comment at line 22
 in custom_tweak:send_deleted_nodes_email:22
HTTPS Please!
Reply | Threaded
Open this post in threaded view
|

Re: Delete messages email

GregChapman
Oops! Looks like I typed a dot for a / in the comment tags. I've edited my original post.

I've also just noticed that there's a bug in Nabble's code handler which shows "lt;" where it should show a <

You need to use the "View plain" link in the code box to copy the original code.

Could be either of those that caused the error - probably my typo!
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
GregHelp - Building a set of answers to Nabble FAQs.
Reply | Threaded
Open this post in threaded view
|

Re: Delete messages email

Harvey
Thanks man.
HTTPS Please!