Bug: This post has NOT been accepted by the mailing list yet

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug: This post has NOT been accepted by the mailing list yet

varvello
I'm registered at the Pharo-users mlist but Nabble does not accept my message.
I've already tried to unsubscribe and subscribe again to the mlist without success.

Moreover every time I write a post, a warning appears asking if i subscribed to the list, every time, even if I preview the message. I guess it is a cookie issue

Can you fix these 2 issues, please?
TIA
Davide
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

GregChapman
I suspect that this post will provide the clues you need to fix the problem:

http://support.nabble.com/list-subscription-tp7598102p7598105.html
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

varvello
Hi Greg,
I don't think the issue is related to the name. Look at this thread: http://forum.world.st/Bloated-image-again-Memory-leak-td4951862.html
You'll see my post that has not been accepted, and after it you'll see the same post from a generic "Pharo Smalltalk Users mailing list"
Davide

GregChapman wrote
I suspect that this post will provide the clues you need to fix the problem:

http://support.nabble.com/list-subscription-tp7598102p7598105.html
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

GregChapman
I think you misunderstand the point I was making in the post at the link I gave.

I believe all the following users are all subscribers to the mail list:

Pharo Smalltalk Users mailing list
Stephane Ducasse-3
philippeback
EstebanLM

However, I believe that whatever address has been recorded by Nabble to be associated  with the username "Davide Varvello" does not appear on the list of subscribers to the original mail list. The message "This post has NOT been accepted by the mailing list yet." is evidence of that.

When any Nabble user posts to the Nabble archive their post will immediately appear on the archive. The post is then forwarded to the mail list. As virtually all mail lists only permit subscribers to post then if there is no subscriber to the mail list with the address registered at Nabble then the post at Nabble is flagged with the message see against the "Davide Varvello" posts.

I can see that you are registered on the archive. That registration is associated with an email address. So my questions are:

1. Are you a subscriber of the mail list?
2. Have you used the same address to register at Nabble as you mail list subscription?

If the answer to either of these questions is "NO" then you get the message you are seeing against posts by "Davide Varvello" at the Nabble archive and subscribers to the list do not receive a copy.

To post to the archive AND have mail list subscribers to receive the post the two email addresses must match.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

varvello
Hi Greg,

Yes I'm a subscriber of the pharo-user mlist and yes, the email I gave to the list is the same one I gave to nabble.
Davide

GregChapman wrote
I think you misunderstand the point I was making in the post at the link I gave.

I believe all the following users are all subscribers to the mail list:

Pharo Smalltalk Users mailing list
Stephane Ducasse-3
philippeback
EstebanLM

However, I believe that whatever address has been recorded by Nabble to be associated  with the username "Davide Varvello" does not appear on the list of subscribers to the original mail list. The message "This post has NOT been accepted by the mailing list yet." is evidence of that.

When any Nabble user posts to the Nabble archive their post will immediately appear on the archive. The post is then forwarded to the mail list. As virtually all mail lists only permit subscribers to post then if there is no subscriber to the mail list with the address registered at Nabble then the post at Nabble is flagged with the message see against the "Davide Varvello" posts.

I can see that you are registered on the archive. That registration is associated with an email address. So my questions are:

1. Are you a subscriber of the mail list?
2. Have you used the same address to register at Nabble as you mail list subscription?

If the answer to either of these questions is "NO" then you get the message you are seeing against posts by "Davide Varvello" at the Nabble archive and subscribers to the list do not receive a copy.

To post to the archive AND have mail list subscribers to receive the post the two email addresses must match.
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

GregChapman
varvello wrote
Yes I'm a subscriber of the pharo-user mlist and yes, the email I gave to the list is the same one I gave to nabble.
Davide
In view of that answer I have to re-think. I looked more closely at the posts in the topic you quote and there is certainly something unusual about it - and I begin to think that a bug may have been introduced into mail list handling recently, but it may be related to customisations in the archive that is confusing Nabble's handling of mail list subscribers.

I see that you appear to be posting under the ID "Pharo Smalltalk Users mailing list" and this is unregistered on the Nabble system - and is also a very unusual username of the like that I have not seen before. I hunted around Nabble  and found another mail list archive http://openssl.6102.n7.nabble.com and that seems to be displaying the same (I believe new) feature.

It has a similar user as on your list archive "OpenSSL - Dev mailing list" and when you view:
http://openssl.6102.n7.nabble.com/template/NamlServlet.jtp?macro=user_nodes&user=6265
you see a topic "Re: Work on a new RNG for OpenSSL" with numerous entries with varying numbers of replies listed. That is definitely abnormal and suggests to me that various mail list subscribers are now being aggregated into a single unregistered user at Nabble, so it is no longer able to link registered users at Nabble with subscribers at the mail list properly and this may be why your posts from the Nabble archive are being rejected.

I also note that both yours and the OpenSSL archive have implemented a change in domain name and wonder if this is related to the bug.

Because I now think this is potentially affecting a large number of users I have raised the issue in Premium Support:
http://support.nabble.com/Bug-in-Mail-List-Archives-td7598220.html

I hope this will result in a solution.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

varvello
Hi Greg,
Thank for submitting the issue to the premium support.

I've just read your post: http://support.nabble.com/Bug-in-Mail-List-Archives-td7598220.html the issue is not recent, I looked at my older messages in the Pharo mlist and you can notice the same problem one year ago: http://forum.world.st/I-can-t-run-Pharo5-on-Linux-Ubuntu-14-04-4-LTS-td4909028.html

Cheers
Davide



GregChapman wrote
varvello wrote
Yes I'm a subscriber of the pharo-user mlist and yes, the email I gave to the list is the same one I gave to nabble.
Davide
In view of that answer I have to re-think. I looked more closely at the posts in the topic you quote and there is certainly something unusual about it - and I begin to think that a bug may have been introduced into mail list handling recently, but it may be related to customisations in the archive that is confusing Nabble's handling of mail list subscribers.

I see that you appear to be posting under the ID "Pharo Smalltalk Users mailing list" and this is unregistered on the Nabble system - and is also a very unusual username of the like that I have not seen before. I hunted around Nabble  and found another mail list archive http://openssl.6102.n7.nabble.com and that seems to be displaying the same (I believe new) feature.

It has a similar user as on your list archive "OpenSSL - Dev mailing list" and when you view:
http://openssl.6102.n7.nabble.com/template/NamlServlet.jtp?macro=user_nodes&user=6265
you see a topic "Re: Work on a new RNG for OpenSSL" with numerous entries with varying numbers of replies listed. That is definitely abnormal and suggests to me that various mail list subscribers are now being aggregated into a single unregistered user at Nabble, so it is no longer able to link registered users at Nabble with subscribers at the mail list properly and this may be why your posts from the Nabble archive are being rejected.

I also note that both yours and the OpenSSL archive have implemented a change in domain name and wonder if this is related to the bug.

Because I now think this is potentially affecting a large number of users I have raised the issue in Premium Support:
http://support.nabble.com/Bug-in-Mail-List-Archives-td7598220.html

I hope this will result in a solution.
Reply | Threaded
Open this post in threaded view
|

Re: Bug: This post has NOT been accepted by the mailing list yet

GregChapman
varvello wrote
I've just read your post: http://support.nabble.com/Bug-in-Mail-List-Archives-td7598220.html the issue is not recent, I looked at my older messages in the Pharo mlist and you can notice the same problem one year ago: http://forum.world.st/I-can-t-run-Pharo5-on-Linux-Ubuntu-14-04-4-LTS-td4909028.html
I don't think that is the case. If you go to your (Davide Varvello) profile page you see that almost all your list of posts are now shown with an icon indicating "not accepted by the mail list". That is patently wrong! There are several posts that have clearly passed through the mail list as they include the distinctive mail list footer that point to the archive.

The aggregation to a maillist username for all non-registered users is the new bit and in doing that it does, as you say, shows all past posts under the new aggregated user name and that has had two side effects. Others posting to the mail list now show the same username as you and it looks as if posts made via the archive are failing.

Until you you started this topic I do not recall ever seeing a user given as the forum name. Nor have I seen the kind of posting list I found on the OpenSSL archive where multiple posters now show as a single user, yet their individual record of posts and replies can be made out through multiple lists of replies. What normally happens is that the initial post on the topic is shown with the full number of replies and each later post will show one less reply against it.

I do run a number of mail lists directly in Nabble (not archives) where non-registered users sign up. In that case their username is taken as the part of their email address before the @ (with a "-2" appended where there are duplicates). It seems that part of the system that is no longer working properly.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!