Bug: Not All Servers Support Polls

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Bug: Not All Servers Support Polls

GregChapman
I wanted to create a poll on a forum operating on the n7 server, but could not find the option required.

I turned to my test forum on the n3 server and the option appear, as documented, together with two further options:

New Post Screen
That made me wonder if it related to my n7 forum being embedded. However, I have another n3 forum which is embedded and the three options appeared there.

I also looked at a forum on the n5 server. That is another, like the n7 forum, that does not show any of the three options, "Alert me" "Email post" or "Add poll" on the Post New Topic screen.

I have further forums on other servers but haven't checked them. In all cases I do have the defaults in place that have the administrator permission to allow posts to be made turned on.

Can you investigate, please.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: Bug: Not All Servers Support Polls

GregChapman
Just checked another forum! The n6 server does seem to be showing all three options:

Alert me by email when someone posts to this thread
Email this post to...
Add new poll

Initially I only saw the first two but "Add Poll" appeared as well after turning on the feature.

My forum on the n4 server is also performing as advertised.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: Bug: Not All Servers Support Polls

Hugo <Nabble>
Administrator
Sorry, I don't follow the explanation. I just checked a forum on the n7 server and the "add poll" option was there. Where exactly it is not showing that option?
Reply | Threaded
Open this post in threaded view
|

Re: Bug: Not All Servers Support Polls

GregChapman
Hi Hugo,

I go to the Create New Topic screen here:
http://ruston-house.1088553.n5.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=1
and
http://aivuk-forum.33396.n7.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=2
and under the main edit box there is just the Post and Preview buttons and Cancel link.

However, at my forums:
http://npopuk-forum.986084.n3.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=2276484
and
http://greg-afloat.969558.n3.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=1641154
and
http://seahawk-forum.968426.n3.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=1595845
and
http://band-forum.2320619.n4.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=817
and
http://ruston-reaches.80608.x6.nabble.com/template/NamlServlet.jtp?macro=new_topic&node=1
I get all three prompts:
Alert me by email when someone posts to this thread
Email this post to...
Add new poll
as well as the Post and Preview buttons and Cancel link.

Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: Bug: Not All Servers Support Polls

Hugo <Nabble>
Administrator
Your forum has customized NAML code, see:
http://ruston-house.1088553.n5.nabble.com/template/NamlServlet.jtp?macro=macro_viewer&id=message_control%21custom_tweak%3Amessage_control&base=nabble.naml.namespaces.BasicNamespace-nabble.view.web.template.NabbleNamespace-nabble.view.web.template.ServletNamespace&breadcrumbs=new_topic%21nabble%3Anew_topic.naml-new_post%21nabble%3Areply.naml-reply_form%21nabble%3Areply.naml

On line 18 we have this:
<n.comment.><n.new_post_extra_fields/> </n.comment.>
Someone commented out the "new_post_extra_fields" macro. This change removes those fields at the bottom of the post form. You can remove the "comment" tags and it should display the polls again.
Reply | Threaded
Open this post in threaded view
|

Re: Bug: Not All Servers Support Polls

GregChapman
Hi Hugo,

Thanks for that. Looks like it's my fault.

I  certainly don't remember having any reason for making that edit on the Ruston Reaches forum, but I guess I did do it on the AIVuk forum as I did want to force users to go to the forum to make posts.

However, in both cases, losing the poll option was an oversight.

I'll see if I can find the right macros/lines to edit to retain the Poll option, while killing the two email options.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!