BUG REPORT: Login Screen Appears When Already Logged In

classic Classic list List threaded Threaded
Assigned to Franklin at priority
 3 
(Normal)
7 messages Options
Reply | Threaded
Open this post in threaded view
|

BUG REPORT: Login Screen Appears When Already Logged In

GregChapman
Hi Franklin,

This bug probably started around two years ago and occurs from time to time in all the embedded forums I operate. I report it now as yet another user is encountering it.

Nabble sometimes presents a login screen when a user is already logged in. When it occurs you do not see the login and register links, but the username of the person logged in.

A workaround is simply to navigate away from the screen with a click/tap on the forum name link at the top left.

However, most newcomers don't realise they have encountered a bug and proceed to attempt to login a number of times and it is annoying for those following permalinks in emails to pages several sub-forums down in the structure as they are utterly broken by the bug.

Unfortunately, I have never been able identify what sets it off and it is relatively rare (I might see it once in a couple of months across the whole range of Nabble forums I maintain) so I have not formally reported it before now, although I have posted the work around to those presenting it on this forum.
Just a Volunteer Nabble Helper - because the nice folk at Nabble have helped me!
Reply | Threaded
Open this post in threaded view
|

Re: BUG REPORT: Login Screen Appears When Already Logged In

Gary Lewis
I'm seeing two different scenarios that look exactly the same, meaning I get a log-in option but my name is showing in the upper right. In one of those scenarios I am apparently already logged in as I can click on the link to my forum up top and it will take me there, or I can click on my name and then go to my posts.

The other scenario looks exactly the same as my name is still showing as if I'm logged in.  However, if I click on the link to my forum it comes right back to that page with the log-in.  And, if I click on my name and then my posts it plays like it is showing my posts but it says I don't have the privileges needed to see them.  So, apparently in this scenario I am not logged in.

This is very confusing to my users as we are all absolute newbies to Nabble.  And we are seeing it frequently when clicking on links sent to us via email, which means we can't get directly to the post to which we are trying to respond.  In other words, once that log-in request comes up you are not going where you wanted to go and now have to go find the thread and post to which you wanted to respond.  Help, please!
Reply | Threaded
Open this post in threaded view
|

Re: BUG REPORT: Login Screen Appears When Already Logged In

Franklin <Nabble>
Administrator
I need to be able to reproduce this.  I registered on your forum.  Please give me some steps to follow to try to reproduce this.  And which browser should I use?
Reply | Threaded
Open this post in threaded view
|

Re: BUG REPORT: Login Screen Appears When Already Logged In

Gary Lewis
Franklin - I am terribly sorry!  I missed your post on my problem report.  Months ago!  I had assumed that by posting I was subscribed to that topic, but that is not the case.  

Anyway, it seems to happen when a person has been inactive for some time, like maybe a day or so.  It acts like the display showing that you are logged in is out of sync with actually being logged in.  So you think you are but actually aren't.

As for what browsers, I've had it happen on Chrome on Win 8 and Win 10, and Safari on iOS 10 and 11.
Reply | Threaded
Open this post in threaded view
|

Re: BUG REPORT: Login Screen Appears When Already Logged In

Gary Lewis
In reply to this post by Franklin <Nabble>
Still having this problem - especially with one key user, 85lebaront2. And it has happened enough that he may leave. 🙈

He’s using Chrome and was Initially only opening a tab to my forum when he wanted to read the mail and see if he needed to reply.  It would show him as logged in and let him type a response, but when he hit Post it required him to log in again and he lost his typing.

Then he tried keeping a tab to the forum open at all times, but that didn’t seem to help. So now he types his response, copies it, and hits Post. Then, if it asks him to re-sign in he says he gets a pretty much blank screen, with the header and essentially nothing else, and if he hits Refresh it will go back to the thread he was on and he can "reply" again, paste and submit.

Thanks in advance for the help. This is a key user I really can’t afford to lose.
Reply | Threaded
Open this post in threaded view
|

Re: BUG REPORT: Login Screen Appears When Already Logged In

haozwang<Nabble>
Administrator
Hi Gary, I posted on the forum for testing and I encountered a similar bug. I can post on the forum while the forum says I'm logged out. then it showed the post with my handle... I'll let franklin know
Reply | Threaded
Open this post in threaded view
|

Re: BUG REPORT: Login Screen Appears When Already Logged In

Gary Lewis
Thanks!  I see that you can not only make yourself a member but an administrator.    Glad you can because I was afraid you were waiting on me to set you up.